Shairport-Sync Firmware für den TP-Link WR710N

Ich habe ja schon vor einigen Monaten geschrieben das es eine neue Shairport Version gibt welche Audiosynchronisations features beeinhaltet.

Nun habe ich endlich die Zeit gefunden für den TP-Link WR710N der die Basis für meine Artikel über den 25€ Airtunes Client darstellt eine neue Firmware zu erstellen.

Diese basiert auf der aktuellen trunk Version von OpenWRT sowie Mike Brady’s Shairport Sync Source. Ich hatte jetzt nicht viel Zeit zum testen, vor allem auch da ich die Lösung zur Zeit nicht aktiv einsetze. Ich bin also auch für ein Feedback dankbar.

Ich werde versuchen in den nächsten Tagen auch eine Anleitung zu posten die beschreibt wie man die Firmware selber bauen kann.

Die aktuelle Firmware könnt ihr hier laden wr710n-shairport-sync. Die Anleitung zum flashen findet Ihr im oben verlinkten Orginal Artikel.

 

8 thoughts to “Shairport-Sync Firmware für den TP-Link WR710N”

  1. Wunderschönen guten Abend!

    DANKE…

    Ich hatte bereits einen funktionieren Shairport mit dem OpenWrt Chaos Calmer r43752 & LuCI Master (git-14.352.03206-43c395a).
    Mit den Startbefehlen:

    /etc/init.d/./shairport stop &
    wait
    /usr/bin/shairport -a LuftSprecher01 -b 238 -d

    war ich extrem nahe am ‚Sync‘ dran.

    Ich habe daher nur das ’sysupdate‘ geflashed – der 710 meldet sich im Itunes direkt als ‚Shairport sync on…‘ und ist sofort ansprechbar. Ich habe vor 10 Minuten geflashed – daher kann ich noch keine Langzeitergebnisse präsentieren.

    Danke nocheinmal für die Bereitstellung des Trunks – ich war nicht in der Lage es selber zu machen… das .git hat hab bei mir schlicht nicht funktioniert.

    Ich bin vor deinem inneren Auge eine einzige Laolawelle!
    Grüße,
    Matthias

    1. Wenn man solche Comments liest dann weis man das man was richtig gemacht hat. Ich habe übrigens auch eine Anleitung erstellt die zeigt wie man die Firmware selber bauen kann. Vielleicht findest du so ja heraus warum es bei dir mit dem FW bauen nicht geklappt hat.

  2. Moin Björn!

    Finales Feedback – der W710N läuft seit dem ersten einschalten durch: einwandfrei!

    Ich starte ihn jedoch mit den Befehlen:

    /etc/init.d/./shairport-sync stop &
    wait
    cd /etc/init.d
    shairport-sync -d -a „LuftSprecher“

    exit 0

    Ich wollte nicht in der config rumfuchteln und der Weg ist zwar nicht 100% aber ein minimalst ‚Workaround‘, für jemanden wie mich, der mit Linux zu wenig Erfahrung hat (…und eine Hilfe für diejenigen, denen es wie mir geht).

    Danke nocheinmal HERZLICHST für die Bereitstellung des BIN – Es gebührt dir alle Ehre und viel Promotion! 😉

    Grüße

  3. Björn,
    vielen vielen Dank für dein erstes Tutorial und jetzt sogar noch das Nachreichen der aktualisierten Version. Großartig!

    Aus aktuellem Anlass wollte ich hier für alle anderen hinterlassen, dass sich bei den openWRT Repositorys wohl etwas geändert hat. Falls jemand noch etwas mehr mit openWRT treiben möchte wird er feststellen dass nichtmal opkg-update durchläuft (weil die Pfade eben nicht mehr passen).

    Nachdem ich heute daran gescheitert bin mir eine aktuelle Version zu kompilieren habe ich einen alternativen Weg gewählt -> Anpassen der okpg.conf (liegt im VZ ~/etc/) und enthält einfach nur ein paar Links. Zwischen „..ar71xx/“ und „/packages..“ muss einfach bei allen Links ein „generic/“ ergänzt werden. Schon seid ihr wieder updatefähig 😉

    …am Rande: Leider habe ich heute wieder keine Konfiguration herstellen können um das Ding als Wlan-Bridge (bridged) und Airplayer gleichzeitig zu verwenden.
    Falls da jemand mehr im Thema steht und hilfsbereit sein möchte – gerne hier melden!

  4. Hallo Björn, find ich klasse dass Du ein vorkompiliertes Binary für shairport-sync bereitstellst! Leider habe ich beim flashen meinen WR710N gebrickt.

    Er hatte den neusten OpenWRT trunk drauf und war frisch zurückgesetzt. Dann habe ich im Wesentlichen folgendes gemacht:
    wget 192.168.178.21:8080/sysupgrade.bin
    mv sysupgrade.bin /tmp
    md5sum => fcb77ba9f2c333e150ac5f21fd69785f /tmp/sysupgrade.bin
    sysupgrade -v /tmp/sysupgrade.bin => … Saving config files…Upgrade completed. Rebooting system…

    Nun komme ich nicht mehr aufs Gerät, weder am WAN- noch am LAN-Port. Oder hast Du in Deinem Image zufällig eine andere IP als 192.168.1.1 eingestellt?

    Da auf meinem openwrt schon ein aktueller Trunk installiert war, hätte ich nicht die sysupgrade.bin sondern die factory.bin flashen müssen, kann das sein? Dann wäre ein Warnhinweis auf Deiner Webseite wahrscheinlich sehr hilfreich…

    Hättest Du sonst einen Tip für mich, wie ich meinen WR710N zum Leben erwecken könnte…

    Lieben Dank & Gruß
    Ulf Brandes, Berlin

    1. Normalerweise sollte der Router auf die Adresse 192.168.1.1 hören, wohlgemerkt wenn ein frischer upgrade durchgeführt wurde.
      Du kannst jetzt versuchen ob du den Router unter dieser Adresse bzw. unter der Adresse anzupingen die er vor dem upgrade hatte.
      Hattest du DHCP vorher aktiviert.

      Ganz ehrlich ich weiss nicht wie sich die neuen Config Files, du hattest ja eine aktuelle Trunk Version drauf, mit der 10 Monate alten Trunk Version verträgt auf welcher mein Build basiert.

  5. So, habe meinen Router mit der seriellen Konsole nun zurückgesetzt. Danke für Deine rasche Antwort. Auf ein Neues!

    Ja, 192.168.1.1 hatte ich mir gedacht. Möglicherweise war der Rückwärts-sysupgrade auf Deine ältere Version tatsächlich das Problem.

    Kannst Du die MD5-Checksummen deiner beiden Binaries auf die Webseite stellen?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.